Простой скрипт для работы с ТСД

Публикация № 593402

Учет и отчетность - Оптовая торговля

ТСД OneScript инвентаризация TCP telnet

14
Небольшой скрипт, исполняемый в среде OneScript, реализует работу TCP-сервера с telnet-клиентом ТСД. Позволяет проводить инвентаризацию товара по штрих кодам с сохранением результатов и протокола в реальном времени на компьютер. Для работы нужен ТСД, имеющий Wi-Fi интерфейс и telnet-клиент.

Как это работает

Для запуска (компиляции) скрипта потребуется OneScript, инструкция по его использованию здесь.

Скрипт последовательно считывает входящий текстовый поток с ТСД, и когда получает завершающий символ строки или полный код (во второй версии скрипта), обрабатывает полученный код и возвращает ответ терминалу.

При запуске скрипт создает файл результатов и файл протокола. Имена файлов содержат текущую дату и код магазина, указанный как параметр при запуске скрипта. Протокол работы ТСД также отображается на сервере в окне командной строки, где запущен скрипт.

Скрипт работает с штрих-кодами EAN13. Каждый промаркированный товар имеет свой уникальный штрих код, состоящий из кода номенклатуры и порядкового номера. Для определения наименования номенклатуры, скрипт подгружает данные из xml файла выгрузки справочника номенклатуры.

Сканер ТСД отправляет отсканированный код скрипту, а он возвращает текущее насчитанное количество данной номенклатуры. В случае повторного сканирования кода, на терминал выводится предупреждающий сигнал и сообщение о повторе кода, количество не увеличивается. Код также можно ввести вручную с клавиатуры ТСД.

В процессе работы можно просмотреть текущие результаты подсчета. Для этого на клавиатуре ТСД нужно нажать 1, завершить работу скрипта - 9. В случае перезапуска скрипта, он подгрузит сохраненные результаты работы. В случае обрыва связи с сервером подсчета кодов не происходит.

Скрипт устанавливает только одно соединение, поэтому при необходимости одновременной работы с несколькими ТСД, можно запускать несколько экземпляров скрипта на разных портах. Скрипт тестировался с клиентом TelnetCE в режиме эмуляции VT200 и кодировкой windows-1251. Вторая версия тестировалась с клиентом ConnectBot под Android.

Немного кода

Процедура работы с клиентом:

Процедура ЗапуститьСервер(Порт)
	
	Сервер = Новый TCPСервер(Порт);
	Сервер.Запустить();
	ПротоколСообщить("Сервер запущен");
	Пока НЕ ОстановитьСервер Цикл
		Соединение = Неопределено;
		Пока Соединение = Неопределено Цикл
			Соединение = Сервер.ОжидатьСоединения(100);
		КонецЦикла;
		Запрос = "";
		ЗапросСтрока = "";
		ПротоколСообщить("Соединение установлено");
		Пока Соединение.Активно И НЕ ОстановитьСервер Цикл
			Если Запрос = "" Тогда
				Попытка
					ЗапросСтрока = ЗапросСтрока + Соединение.ПрочитатьСтроку("windows-1251");
				Исключение
					Продолжить
				КонецПопытки;
				Если НЕ Прав(ЗапросСтрока, 1) = Символы.ВК Тогда
					Продолжить
				КонецЕсли;
				Запрос = СтрЗаменить(ЗапросСтрока, Символы.ПС, "");
				Запрос = СтрЗаменить(Запрос, Символы.ВК, "");
				Запрос = СтрЗаменить(Запрос, "A", "");
				ЗапросСтрока = "";
				ТекВремя = Формат(ТекущаяДата(), "ДЛФ=T");
				Если СтрДлина(Запрос) = 1 Тогда
					Если Запрос = "1" Тогда
						ПоказатьРезультаты();
					ИначеЕсли Запрос = "2" Тогда
						Прервать;
					ИначеЕсли Запрос = "9" Тогда
						ОстановитьСервер = Истина;
					КонецЕсли;
					Запрос = "";
				ИначеЕсли СтрДлина(Запрос) = 13 Тогда
					Код = Сред(Запрос, 2, 6);
					ТекКоличество = Количество.Получить(Код);
					Если НЕ ТекКоличество = Неопределено Тогда
						ТекКоличество = 1 + ТекКоличество;  
						Ответ = "" + ТекКоличество + " - " + Номенклатура.Получить(Код) + " - " + Запрос;
						НайтиПовтор = ШхКоды.Получить(Запрос);
						Если НЕ ЗначениеЗаполнено(НайтиПовтор) Тогда
							Количество.Вставить(Код, ТекКоличество);
							ШхКоды.Вставить(Запрос, ТекВремя);
							Результаты.ЗаписатьСтроку(Запрос);
						Иначе
							Ответ = Символ(7) + "Повтор кода: " + Запрос + " (" + НайтиПовтор + ")"; 
						КонецЕсли;
					Иначе
						Ответ = Символ(7) + "Неверный / неизвестный код: " + Запрос;
					КонецЕсли
				Иначе
					Ответ = Символ(7) + "Неверный код / команда: " + Запрос;
				КонецЕсли;
			Иначе
				Попытка
					ОтправитьОтвет(Ответ);
					Запрос = "";
				Исключение
				КонецПопытки;
			КонецЕсли
		КонецЦикла;
		Соединение.Закрыть();
		ПротоколСообщить("Соединение закрыто");
	КонецЦикла;
	Сервер.Остановить();
	ПротоколСообщить("Сервер остановлен");

КонецПроцедуры

 

Вторая версия скрипта:

Процедура ЗапуститьСервер(Порт)
	
	Сервер = Новый TCPСервер(Порт);
	Сервер.Запустить();
        ПротоколСообщить("Сервер запущен на порту: " + Порт);
        ПротоколСообщить("Дата инвентаризации: " + ФорматДата);

	Запрос = "";
	Ответ = "";
	ЗапросСтрока = Неопределено;
	
	Пока НЕ ОстановитьСервер Цикл
		Соединение = Неопределено;
		Пока Соединение = Неопределено Цикл
			Соединение = Сервер.ОжидатьСоединения(200);
		КонецЦикла;
		Соединение.ТаймаутОтправки = 300; 
		Соединение.ТаймаутЧтения = 300;
		ПротоколСообщить("Соединение установлено");
		ОтправитьОтвет("Дата инвентаризации: " + ФорматДата + ПСВК);
		ТекВремя = Формат(ТекущаяДата(), "ДЛФ=T");
		ОтправитьОтвет(ТекВремя + " Соединение установлено" + ПСВК);
		Ошибки = 0;
		Пока Соединение.Активно И НЕ ОстановитьСервер И Ошибки < 5 Цикл
			ОтправитьОтвет(Символы.ВК);
			Если ЗапросСтрока = Неопределено Тогда
				ОтправитьОтвет(">");
				ПротоколСообщить(">");
			КонецЕсли;
			Попытка
				ЗапросСтрока = "";
				ЗапросСтрока = Соединение.ПрочитатьСтроку("windows-1251");
				ЗапросСтрока = СтрЗаменить(ЗапросСтрока, Символы.ПС, "");
				ЗапросСтрока = СтрЗаменить(ЗапросСтрока, Символы.ВК, "");
				Запрос = Запрос + ЗапросСтрока;
				//ЗапросСтрока = СтрЗаменить(ЗапросСтрока, "A", "");
			Исключение
				Если Запрос = "" Тогда
					Продолжить
				КонецЕсли;
			КонецПопытки;
			Если Запрос = "1" Тогда
				ОтправитьОтвет(ПСВК);
				ПоказатьРезультаты();
                Запрос = "";
				ЗапросСтрока = Неопределено;
				Продолжить;
			ИначеЕсли Запрос = "2" И ЗапросСтрока = "2" Тогда
				ОтправитьОтвет(ЗапросСтрока);
				ПротоколСообщить(ЗапросСтрока);
				Пока СтрДлина(Запрос) < 13 И Соединение.Активно И НЕ ОстановитьСервер И Ошибки < 5 Цикл
					Попытка
						ЗапросСтрока = "";
						ЗапросСтрока = Соединение.ПрочитатьСтроку("windows-1251");
						ЗапросСтрока = СтрЗаменить(ЗапросСтрока, Символы.ПС, "");
						ЗапросСтрока = СтрЗаменить(ЗапросСтрока, Символы.ВК, "");
						Запрос = Запрос + ЗапросСтрока;
						//ЗапросСтрока = СтрЗаменить(ЗапросСтрока, "A", "");
						ОтправитьОтвет(ЗапросСтрока);
						ПротоколСообщить(ЗапросСтрока);
					Исключение
					КонецПопытки;
				КонецЦикла;
				ОтправитьОтвет(ПСВК);
			ИначеЕсли Запрос = "9" Тогда
				ОстановитьСервер = Истина;
				Прервать;
			КонецЕсли;
			Если Лев(Запрос, 1) = "2" Тогда
				Если СтрДлина(Запрос) >= 13 Тогда
					ТекВремя = Формат(ТекущаяДата(), "ДЛФ=T");
					стрКод = Лев(Запрос, 13);
					Код = Сред(стрКод, 2, 6);
					ТекКоличество = Количество.Получить(Код);
					Ответ = стрКод + " " + ПСВК;
					Если НЕ ТекКоличество = Неопределено Тогда
						НайтиПовтор = ШхКоды.Получить(стрКод);
						Если НЕ ЗначениеЗаполнено(НайтиПовтор) Тогда
							ТекКоличество = 1 + ТекКоличество;  
							Ответ = Ответ + " " + Номенклатура.Получить(Код) + " #" + ТекКоличество;
							Количество.Вставить(Код, ТекКоличество);
							ШхКоды.Вставить(стрКод, ТекВремя);
							Результаты.ЗаписатьСтроку(стрКод);
						Иначе
							Ответ = Ответ + Символ(7) + "!Повтор кода (" + НайтиПовтор + ")"; 
						КонецЕсли;
					Иначе
						Ответ = стрКод + " " + ПСВК + Символ(7) + "Неверный код / команда";
					КонецЕсли;
					Запрос = Сред(Запрос, 14);
					ПротоколСообщить(Ответ);
					ОтправитьОтвет(Ответ + ПСВК);
					ЗапросСтрока = Неопределено;
					Продолжить
				КонецЕсли;
			КонецЕсли;
			Ответ = Запрос + " " + ПСВК + Символ(7) + "Неверный код / команда";
			ПротоколСообщить(Ответ);
			ОтправитьОтвет(Ответ + ПСВК);
			Запрос = "";
			ЗапросСтрока = Неопределено;
		КонецЦикла;
		Соединение.Закрыть();
		ПротоколСообщить("Соединение закрыто");
	КонецЦикла;
	Сервер.Остановить();
	ПротоколСообщить("Сервер остановлен");

КонецПроцедуры

Как использовать

Данный скрипт не является универсальным решением, т.к. писался под конкретную задачу. Можно взять его за основу и немного доработав, например, передавать данные напрямую в конфигурацию 1С.

14

Скачать файлы

Наименование Файл Версия Размер
ws.os
.os 9,77Kb
02.03.17
1
.os 9,77Kb 1 Скачать
ws2.os
.os 12,59Kb
10.05.18
0
.os 12,59Kb Скачать

Специальные предложения

Избранное Подписка Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение

См. также

Базовый курс для начинающих 1С-программистов. Пятый поток. Онлайн-курс с 12 февраля по 15 апреля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500/9500 рублей

Компактный шаблон чека для ККТ Атол 5

Отчеты и формы Программист Архив с данными Розничная и сетевая торговля (FMCG) Россия Розничная торговля Абонемент ($m) Печатные формы документов

Всем привет! Сделали для себя максимально компактный шаблон кассового чека. В стандартном шаблоне место используется, скажем так, не очень рационально. Если вы устали менять кассовую ленту несколько раз в день, а самому возиться с редактором шаблонов лениво, то этот шаблон для вас. Шаблон тестировался на кассе Атол 22Ф (АТОЛ FPrint-22ПТК), ширина чека 48 символов (80мм).

1 стартмани

02.08.2019    3047    5    Rans    2       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Импорт товаров в весы Масса-К ВПМ, вместе с составом товаров, одним махом 0

Инструменты и обработки Программист Архив с данными Розничная торговля Абонемент ($m) Весы

В двух словах: заполненный выложенный в архиве Excel документ вам присылают Клиенты (они дополняюют его из 1С допустим, это база товаров). Вы этот докуент конвертируете с помощью конвертера(он в архиве) в промежуточную .dbf базу. И потом ее загружаете в Менеджер данных Про и корректируете. Это почти одним махом делается импорт в весы ВПМ Этот способ описывает Импорт товаров в базу программы Менеджер данных PRO, а затем в весы ВПМ. Здесь я описываю тот случай, когда 1) у Клиента нет в 1С базы весовых товаров, которые ему необходимо загрузить в весы ВПМ. Номенклатуры весовых товаров очень много, и у каждого товара есть Состав, причем состав Клиенту нужен на 2-х языках (на русском и на государственном местном, допустим, Казахском или Татарском) 2) Когда у Клиента есть в 1С есть все весовые товары, но в Карточках Товара отсутствует Состав Товара Часто при выгрузке из 1С и при этом способе, при дальнейшем редактировании товаров, не удается сохранить изменения в Менеджер Данных PRO, выходит такая ошибка "Could not convert variant of type "NULL" into type "OleStr". В инструкции я описываю, как ее устранить.

1 стартмани

25.06.2019    1700    1    brotherm    0       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Сверка 76.АВ с книгой покупок по ставкам НДС 18% и 20%. Проверка зачета аванса по ставкам НДС 18% и 20% в 1 квартале 2019 г. Переход на 20% НДС. Закрытие квартала 18% и 20% НДС 1

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::БУ 1С7:Комплекс Россия БУ Оптовая торговля НДС Абонемент ($m) Бухгалтерские Анализ учета

Отчет написан для Комплексной конфигурации 4.2. Отчет позволяет выполнить сверку кредитовых оборотов счета 76.АВ (НДС с авансов полученных) с книгой покупок, проверить правильность выписки счетов фактур на зачет аванса по счетам БУ в разрезе разных ставок НДС 18% и 20% в комплексной конфигурации 1С:Предприятия 7.7. Позволяет найти и исправить ошибки в процессе перехода на 20% НДС. Помогает с закрытием квартала 18% и 20% НДС. Отчет обновлен для анализа данных 2 квартала 2019 года и всех следующих кварталов (стал более универсальным).

1 стартмани

27.03.2019    7829    6    ksnik    5       

Очный семинар по регулярному менеджменту Александра Фридмана "Вы или Хаос", 12 декабря 2019 г. , Санкт-Петербург Промо

Семинар по регулярному менеджменту от Александра Фридмана для собственников, первых лиц и топов. Технология управленческого планирования, комплексного управления временем и другими ресурсами, выполнением поручений, делами, информацией, контактами (встречи-звонки-почта).

от 11000 до 29000 рублей

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь новая версия - Simple UI (обновлено 14.11.2019) 178

Инструменты и обработки Программист Архив с данными v8 v8::Mobile БУ УУ Android Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Абонемент ($m) Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    25087    229    informa1555    189       

Анализ активности продавцов для УТ 11 3

Отчеты и формы Бизнес-аналитик Пользователь Руководитель проекта Внешний отчет (ert,erf) v8 v8::ОУ v8::СКД УТ11 Розничная и сетевая торговля (FMCG) Россия УУ Розничная торговля Абонемент ($m) Управленческие

Отчет позволяет проанализировать качество работы продавцов, а также сравнить показатели розничных точек продаж (магазинов).

5 стартмани

26.11.2018    3897    Zalipaka    0       

Перенос документов и справочников ERP 2 / КА 2 / УТ 11 => БП 3.0 Промо

Перенос позволяет настроить собственный обмен данными между указанными программами, альтернативный предлагаемому фирмой 1С. Предоставляем техподдержку по всем вопросам данного обмена. Можем подключиться к вам удаленно для разбора ситуаций. Оперативно обновляем при выходе новых релизов 1С. Бесплатные обновления в течение полугода.

19700 руб.

Расширение "Интерфейс Плюс" 44

Отчеты и формы Бухгалтер Пользователь Расширение (cfe) v8 v8::ОУ Розница УТ11 Россия УУ Розничная торговля Абонемент ($m) Рабочее место

Расширение для 1С:Розница 2.2 и 1С:Управление Торговлей 11, которое позволит повысить удобство работы!

3 стартмани

22.09.2018    11881    98    RocKeR_13    82       

Как просто прочитать чеки из фискального накопителя на вашем ПК 38

Статья Системный администратор Архив с данными Розничная и сетевая торговля (FMCG) Россия Розничная торговля Абонемент ($m) ККМ

Переходник ФН-ПК USB за примерно 100 рублей. В работе часто бывают ситуации, когда нужно подключить фискальный накопитель к ПК. Ну например, касса не работает, восстанавливать работоспособность кассы неоправданно дорого, а закрыть фискальный накопитель и передать чеки в ИФНС все же нужно.

1 стартмани

12.09.2018    16971    7    roman3d    30       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Помощник корректировки остатков ЕГАИС в небольшом магазине. Розница 2.2 12

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Розничная торговля Абонемент ($m) Обработка документов

Данная обработка упрощает корректировку остатков алкогольной продукции небольшого магазина, где предполагается передача всей продукции в торговый зал сразу после приемки.

5 стартмани

08.09.2018    17375    78    asdfgcom    45       

Рабочее Место Кассира (РМК+) для фискальных регистраторов АТОЛ (всех) и Штрих (тоже всех), без 1С и вообще без АСУТ 7

Инструменты и обработки Бухгалтер Руководитель проекта Архив с данными Россия Windows Кассовые операции Розничная торговля Абонемент ($m) Фискальный регистратор Рабочее место

Не хотите покупать 1С? У вас всего 5-10 товаров или услуг? Тогда это решения для вас! Проложение Рабочее Место Кассира+ (РМК+) решает 1 задачу: соблюдение 54-ФЗ Приложение позволяет печатать чеки на фискальных регистраторах Атол и Штрих без покупки 1С. При этом выполняются все требования 54-ФЗ! Ели вам нет необходимости внедрять учет, если вам не нужно ничего, кроме печати чеков - РМК+ самое дешевое решение на рынке. Отличительная особенность: открытый код на VBS

1 стартмани

07.09.2018    5721    5    mat skywalker    10       

Новогодние скидки на авторское ПО Промо

В преддверии праздника в Маркетплейсе на Инфостарт действует скидка на все платные авторские программы. Размер скидок начинается от 10%. Советуем не откладывать покупки, многие наши партнеры повышают цены на свои продукты именно в начале нового года.

ЕГАИС 3 Контролёр для 1С:Розница 7

Инструменты и обработки Системный администратор Пользователь Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Android Розничная торговля Абонемент ($m) Терминал сбора данных

Оградите себя от рисков отзыва лицензии на торговлю алкоголем, штрафов и блокировок в ЕГАИС. Проверяйте поступающую алкогольную продукцию помарочно на соответствие ТТН ЕГАИС v3 перед тем, как подтвердить получение и принять её на баланс в ЕГАИС. С 01.07.2018 начинается переход ЕГАИС на помарочный учет алкогольной продукции на всех стадиях товародвижения, начиная от производства или ввоза на территорию России, до реализации в розничной торговле, т.н. "ЕГАИС 3.0". В типовой Рознице уже появилась обработка для контроля поступивших акцизных марок на ПК. Предлагаю ознакомиться с мобильным решением. Контроль производится в Android приложении на ТСД или на обычном смартфоне.

1 стартмани

13.06.2018    11363    16    kuld    30       

Пробитие чеков через ККМ в офисе (для курьеров) 12

Инструменты и обработки Пользователь Расширение (cfe) v8 v8::ОУ Розница УТ11 Россия БУ Кассовые операции Розничная торговля Абонемент ($m) ККМ Фискальный регистратор

Предлагается интеграция 1С с ККТ СтарРус. Поддерживается одновременная работа с разных рабочих мест. ККТ СтарРус работает как сервер, и принимает команды через API по http-протоколу, что позволяет пробивать чеки через центральную базу 1С для интернет-магазина и для курьеров.

1 стартмани

07.06.2018    20247    27    Kutuzov    12       

Перенос данных КА 1.1 => ERP 2 (ЕРП) (обработка переноса документов, остатков и справочной информации из "1С:Комплексная автоматизация, ред. 1.1" в "1С:ERP Управление предприятием, ред 2"). Обновлен до КА 1.1.115.х и ERP 2.4.10.х Промо

Обработка позволяет переносить из КА 1.1 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления в случае выхода новых релизов конфигураций 1С.

29700 руб.

Валовая прибыль в текущем месяце. Актуальная себестоимость (рассчитывается из последней цены закупки с учетом доп.расходов) 14

Отчеты и формы Бизнес-аналитик Пользователь Руководитель проекта Внешний отчет (ert,erf) v8 v8::ОУ УТ11 УУ Оптовая торговля Учет доходов и расходов Абонемент ($m) Управленческие

Валовая прибыль "Вместо себестоимости - Закупочные цены + Доп. расходы". Дополнительный внешний отчет для конфигурации Управление торговлей 11. Отчет поможет предприятиям, если нет возможности: - закрывать месяц ежедневно; - считать себестоимость вообще по разным причинам. В отчет попадают закупочные цены на *конецпериода* формирования отчета + дополнительные расходы.

7 стартмани

16.03.2018    14738    65    zaika007    43       

Время продаж чеков по магазинам в УТ 11, КА. Аналитический отчет + Диаграмма 7

Отчеты и формы Руководитель проекта Внешний отчет (ert,erf) v8 v8::ОУ УТ10 УТ11 КА2 Розничная и сетевая торговля (FMCG) УУ Розничная торговля Абонемент ($m) Управленческие

Отчет "Диаграмма по времени продаж чеков" предназначен для планирования графиков работы продавцов-менеджеров, для планирования маркетинговых мероприятий.

2 стартмани

16.03.2018    12546    8    zaika007    12       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Отчет по среднему чеку в торговле УТ 11; КА 2 9

Отчеты и формы Руководитель проекта Внешний отчет (ert,erf) v8::ОУ v8::УФ УТ11 УУ Розничная торговля Абонемент ($m) Управленческие

Данный отчет позволяет посмотреть средние чеки в разрезе продавцов, магазинов и ККМ в конфигурации "Управление торговлей 11". Данный отчет был протестирован на всех версиях конфигурации Управление торговлей 11*Х. и КА 2*Х

3 стартмани

15.03.2018    12422    20    zaika007    15       

Автоматизация отдела продаж - CRM конфигурация для небольшой компании 14

Отчеты и формы Руководитель проекта Конфигурация (md, cf) v8 Россия УУ Управление взаимоотношениями с клиентами (СRM) Оптовая торговля Абонемент ($m) Управленческий учет (прочее)

Вам нужна несложная и многофункциональная автоматизированная система управления продажами для автоматизации отдела продаж? Наша CRM Система поможет Вам! Внедрение займет не более 15 минут. A-CRM - быстрая и безболезненная автоматизация отдела продаж. Без лишних затрат и сложностей. Интеграция с 1С Бухгалтерией 3 и 1С УТ 11.

1 стартмани

05.03.2018    13800    37    user718500    12       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Построение маршрута доставки с расчётом расстояния для любой базы УФ 57

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Оптовая торговля Абонемент ($m) Универсальные обработки WEB

Графическое изображение маршрутного листа по картам гугл. Работает на любой конфигурации с управляемыми формами. Использует новую версию api google-карт от 13.02.2018 года под IE11.

10 стартмани

24.02.2018    21876    36    KorotkovRV    16       

Анализ распределения заказов по предоплатам 6

Отчеты и формы Бизнес-аналитик Внешний отчет (ert,erf) v8 УПП1 УУ Оптовая торговля Абонемент ($m) Статистические

Отчет, в котором предоплаты разделены по интервалам (порогам) предоплат.

1 стартмани

21.02.2018    10220    1    wowik    0       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Кассовая программа "Касса" 5

Инструменты и обработки Системный администратор Бухгалтер Архив с данными БУ Windows Кассовые операции Розничная торговля Абонемент ($m) ККМ Фискальный регистратор

Кроме функционала, который есть практически во всех подобных программах, в нашей программе есть две очень полезные функции: во-первых, если вам или вашим сотрудникам, нужно постоянно знать текущую наличную и безналичную выручку во всех кассах всех ваших магазинов, то это можно сделать, обзвонив все ваши магазины, или просто установить приложение в смартфон и настроить программу Касса на всех рабочих местах кассиров во-вторых, возможно вам нужно пробивать чеки на ККМ из любого современного браузера, для этого нужно просто включить настройку в нашей программе и попросить вашего веб-программиста написать несложный код, пример которого, мы предоставим

1 стартмани

16.02.2018    11501    10    ioff83    5       

Корректировка остатков ЕГАИС, возврат из регистра 2, загрузка ТТН из файлов, другое для УТ10.3 15

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::ОУ УТ10 Россия БУ Розничная торговля Абонемент ($m) Обработка документов

Набор обработок для автоматизации работы с ЕГАИС: Обработка корректировки остатков ЕГАИС для УТ 10.3, аналогичная имеющимся в УТ 11, Рознице 2.2. Автоматически формирует документы "Передача в торговый зал", "Акт постановки на баланс в торговом зале", "Акт списания в торговом зале". Обработка возврата из регистра 2 с подбором справок Б. Обработка формирования ТТН из файлов xml.

1 стартмани

24.01.2018    20141    5    biz-intel    3       

Перенос данных БП 3.0 => УТ 11 / КА 2 / ERP 2 (ЕРП) (перенос остатков, документов и справочной информации из "1С:Бухгалтерия предприятия 8", ред.3.0). Обновлено до БП 3.0.73.х, УТ 11.4.10.х, КА 2.4.10.х., ERP 2.4.10.х! Промо

Переносятся документы за выбранный период, справочная информация и остатки по счетам бух. учета в программу УТ 11 / КА 2 / ЕРП 2 (ERP). Переносятся все возможные виды операций ввода остатков на нужную дату. Есть отбор по периоду переноса документов и фильтр по организации, доступен выбор даты ввода остатков. Если нужно переносить что-то дополнительно, то обычно бесплатно добавляем это в перенос . Смотрите видеодемонстрацию со звуком - советами по переносу и рекомендациями настройки программ.

29700 руб.

КАССА Mobile 54-ФЗ 13

Инструменты и обработки Бухгалтер Пользователь Архив с данными Розничная и сетевая торговля (FMCG) БУ УУ Android Кассовые операции Розничная торговля Абонемент ($m) ККМ Фискальный регистратор Управление торговлей

Кассовые операции розничной торговли на смартфоне соответственно 54-ФЗ. Подключение фискального регистратора с ФН, отправка чеков ОФД.

3 стартмани

29.12.2017    12840    5    O-Planet    14       

Плагин для Internet Explorer, при просмотре автоматически сохраняющий журнал продаж ЕГАИС 3

Инструменты и обработки no Архив с данными Розничная и сетевая торговля (FMCG) Россия Windows Розничная торговля Абонемент ($m) WEB

Плагин для браузера Internet Explorer, автоматически сохраняющий при просмотре журнал продаж ЕГАИС в файлы на жестком диске.

1 стартмани

22.12.2017    6757    1    nooby123    2