Сканирование QR кодов через WEB-камеру

Публикация № 595637

Разработка - Разработка внешних компонент

Программа вэб камера qr код

6
Программа для считывания QR кодов через вэб-камеру.

Программа не требует установки. Единственное условие - наличие установленного framework 4.0 и старше. Состоит из двух библиотек и выполняемого файла.

1. Запускаем программу. 

2. Подносим QR код.

3. Программа считывает и закрывается. 

В каталоге программы создается файл Output.txt с одной строкой формата: True|563067. Первый параметр  "True" или "False" - статус сканирования. Второй - штрих код или описание ошибки.

Пример процедуры чтения QR кода. Используется для чтения кодов UDS GAME со смартфонов покупателей. 

Процедура ОсновныеДействияФормыСканироватьКодUDS(Кнопка)
	
	КаталогИБ = КаталогИБ();
	Если КаталогИБ = КаталогВременныхФайлов() Тогда
		КаталогИБ = КаталогДокументов();
	КонецЕсли; 
	КаталогИБ = КаталогИБ+"QRreader\";
	
	МассивФайловРезультата = НайтиФайлы(КаталогИБ,"output.txt",Истина);
	Если НЕ МассивФайловРезультата.Количество() = 0 Тогда
		ФайлРезультата = МассивФайловРезультата[0];
		УдалитьФайлы(КаталогИБ+"output.txt");
	КонецеслИ;
	
	МассивФайлов = НайтиФайлы(КаталогИБ,"QRDecoder.exe",Истина);
	Если МассивФайлов.Количество() = 0 Тогда
		Предупреждение("Не установлена программа для чтения QR-кодов!", 60);
	Иначе
		ФайлQRreader = МассивФайлов[0].ПолноеИмя;
		ЗапуститьПриложение(ФайлQRreader, КаталогИБ, Истина,);
		
		МассивФайловРезультата = НайтиФайлы(КаталогИБ,"output.txt",Истина);
		Если НЕ МассивФайловРезультата.Количество() = 0 Тогда
			ФайлРезультата = МассивФайловРезультата[0];
	        ТД = Новый ТекстовыйДокумент;
			ТД.Прочитать(КаталогИБ+"output.txt");
			СтрокаОтвета = ТД.ПолучитьСтроку(1);
			Если СтрокаОтвета <> "" Тогда
				ПозицияРазделителя = Найти(СтрокаОтвета, "|");
				Если ПозицияРазделителя <> 0 Тогда
					ОтветПрограммы = Лев(СтрокаОтвета, ПозицияРазделителя-1); 
			        Если ОтветПрограммы = "True" Тогда
						КодСкидкиUDS = Сред(СтрокаОтвета, ПозицияРазделителя+1, СтрДлина(СтрокаОтвета)-ПозицияРазделителя);
						Если КодСкидкиUDS <> "" Тогда
							
							Отказ = Ложь;
							ИмяКлиента = "";
							СуммаСкидки = 0;
							ОтветСкидки = UDSGame.GET_Customer(КодСкидкиUDS); 
							ЧтениеJSON = Новый ЧтениеJSON;
							ЧтениеJSON.УстановитьСтроку(ОтветСкидки);
							
							СтруктураОтвета = ПрочитатьJSON(ЧтениеJSON, ,"dateCreated");
							
							Если СтруктураОтвета.Свойство("scores") Тогда 
								СуммаСкидкиUDS = СтруктураОтвета.scores; 
							КонецЕсли;
							
							Если СтруктураОтвета.Свойство("name") Тогда
								nameUDS = СтруктураОтвета.name;
							КонецЕсли;
							
							Если СтруктураОтвета.Свойство("surname") Тогда
								surnameUDS = СтруктураОтвета.surname;
							КонецЕсли;
							
							Если СтруктураОтвета.Свойство("errorCode") Тогда
								Предупреждение("Получена ошибка: " + СтруктураОтвета.errorCode, 60);
								Отказ = Истина;
							КонецЕсли;
							
							Если Не Отказ Тогда
								ЭтаФорма.Закрыть();
							КонецЕсли; 
							
						Иначе
							Предупреждение("Не удалось считать код. Попробуйте считать снова.",60);	
						КонецЕсли; 
					Иначе
						Предупреждение("Не удалось считать код. Попробуйте считать снова.",60);
					КонецЕсли; 
				Иначе
					Предупреждение("Не удалось считать код. Попробуйте считать снова.",60);	
				КонецЕсли; 
			КонецЕсли; 
		КонецЕсли; 
	КонецЕсли;
	
КонецПроцедуры

6

Скачать файлы

Наименование Файл Версия Размер
QRreader.zip
.zip 161,39Kb
09.03.17
19
.zip 161,39Kb 19 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
2. Sergik_D 17 21.11.17 09:47 Сейчас в теме
(0) Здравствуйте. Не понял что Вам скинуть? Я код описал работы с программой. У меня не стандартная конфигурация, она Вам не подойдет. Если нужно интегрировать, напишите, обсудим.
3. Vladimir45 64 28.02.18 13:53 Сейчас в теме
А как указать что надо использовать не фронтальную, а заднюю камеру на планшете с виндой?
4. Crazy_Max 62 15.06.18 07:33 Сейчас в теме
А может быть исходный код библиотеки выложите, если вы его не распространяете в коммерческих целях? Хотелось бы сэкономить время и дополнить тот функционал, который хотелось бы лично мне...
Оставьте свое сообщение

См. также

Маленькая и скромная мобильная внешняя компонента 46

Вопрос Программист Архив с данными v8 Абонемент ($m) Разработка внешних компонент

Изваять простенькую мобильную компоненту на 1С для android не так-то просто. Посему назло отдельным супостатам, не желающим делится исходниками, представляю весь свой скромный труд на публичный суд.

1 стартмани

21.10.2019    3733    1    ripreal1    12       

Перенос данных КА 1.1 => ERP 2 (ЕРП) (обработка переноса документов, остатков и справочной информации из "1С:Комплексная автоматизация, ред. 1.1" в "1С:ERP Управление предприятием, ред 2"). Обновлен до КА 1.1.115.х и ERP 2.4.10.х Промо

Обработка позволяет переносить из КА 1.1 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления в случае выхода новых релизов конфигураций 1С.

29700 руб.

Native внешняя компонента для оповещения по UDP или TCP 36

Инструменты и обработки Программист Архив с данными v8 Windows Абонемент ($m) Разработка внешних компонент

Native внешняя компонента для оповещения по UDP или TCP, которая реализует возможность в 1С передавать сообщения с сервера на клиента. Исходный код компоненты также представлен.

1 стартмани

06.10.2019    3206    7    vdv2701    10       

Рекомендательный сервис на основе коллаборативной фильтрации на 1С. Расширение формы подбора для УТ 11.4 32

Инструменты и обработки Программист Расширение (cfe) v8 ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m) Оптовая торговля Розничная торговля Практика программирования Математика и алгоритмы

В данной разработке реализован механизм рекомендаций товаров по принципу схожести товаров в корзине на основе алгоритма Item-to-Item от Amazon. Разобран алгоритм с демо базой и сделано расширение для УТ11.4 которое добавляет в форму подбора таблицу рекомендаций. Протестировано на 8.3.13.1865 на Управление торговлей, редакция 11 (11.4.8.63)

3 стартмани

25.09.2019    3134    6    informa1555    21       

Онлайн-интенсив "Бизнес-процессы для подготовки к экзамену 1С:Специалист по платформе" 12 декабря 2019 г. Промо

На интенсиве будут рассмотрены все теоретические вопросы, связанные с устройством механизма бизнес-процессов – это необходимо для успешной сдачи экзамена 1С:Специалист по платформе. Также, в качестве практического примера, будет решена задача, аналогичная экзаменационной.

777 рублей

Выгрузка номенклатуры в социальную сеть Вконтакте 32

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Оптовая торговля Розничная торговля Абонемент ($m) WEB

Обработка для быстрой и легкой выгрузки товаров Вконтакт. Так просто еще не было)))

2 стартмани

14.08.2019    3988    14    kalyuzhny    23       

Создание платежного поручения по QR-коду 1

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8::БУ БП2.0 БУ Банковские операции Абонемент ($m) Обработка документов

Автоматическое создания платежного поручения по QR-коду (ГОСТ Р 56042-2014 Стандарты финансовых операций) для типовой Бухгалтерии 2.0. Тестировалось на платформе 8.3.13.1644, конфигурации 1С: Бухгалтерия 2.0.66.81.

1 стартмани

12.08.2019    1371    rav_    0       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Перенос данных УПП 1.3 => ERP 2 (ЕРП) / УТ 11 / КА 2.х (обработка переноса документов, остатков и справочников из "1С:Управление производственным предприятием, ред. 1.3" в ERP / УТ 11 / КА 2). Обновлен до УПП 1.3.127.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Обработка позволяет переносить из УПП 1.3 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления при выходе новых релизов конфигураций 1С.

29700 руб.

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь новая версия - Simple UI (обновлено 14.11.2019) 178

Инструменты и обработки Программист Архив с данными v8 v8::Mobile БУ УУ Android Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Абонемент ($m) Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    24550    225    informa1555    174       

Анализ активности продавцов для УТ 11 3

Отчеты и формы Бизнес-аналитик Пользователь Руководитель проекта Внешний отчет (ert,erf) v8 v8::ОУ v8::СКД УТ11 Розничная и сетевая торговля (FMCG) Россия УУ Розничная торговля Абонемент ($m) Управленческие

Отчет позволяет проанализировать качество работы продавцов, а также сравнить показатели розничных точек продаж (магазинов).

5 стартмани

26.11.2018    3773    Zalipaka    0       

Очный семинар по регулярному менеджменту Александра Фридмана "Вы или Хаос", 12 декабря 2019 г. , Санкт-Петербург Промо

Семинар по регулярному менеджменту от Александра Фридмана для собственников, первых лиц и топов. Технология управленческого планирования, комплексного управления временем и другими ресурсами, выполнением поручений, делами, информацией, контактами (встречи-звонки-почта).

от 11000 до 29000 рублей

Внешняя компонента для выполнения регулярных выражений 59

Инструменты и обработки Программист Архив с данными v8 Абонемент ($m) Разработка внешних компонент

Внешняя Native API компонента для выполнения регулярных выражений на платформе 1С:Предприятие 8. Написана на C++. Используется движок boost::regex (v 1.69, v 1.68 - для Android). Версия синтаксиса Perl Compatible Regular Expressions.

1 стартмани

12.11.2018    6844    21    KAV2    57       

Загрузка чека онлайн-касс (загрузка товаров из чека) 38

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Кассовые операции Розничная торговля Абонемент ($m) Внешние источники данных WEB

Обработка-пример, позволяет любому и из любой конфигурации загрузить информацию о товарах из чека(и не только) с сервера ФНС proverkacheka.nalog.ru

2 стартмани

08.10.2018    9030    23    echo77    32       

Перенос документов, остатков и справочников КА 1.1 => КА 2 / УТ 11. Обновлено до КА 2.4.10.х и УТ 11.4.10.х! Промо

Более 130 компаний выполнили переход на КА 2 или УТ 11 с помощью нашей разработки! Позволяет перенести не только остатки и справочники (как типовая обработка), но и документы за нужный период времени. Предоставляем техподдержку, оперативно исправляем замечания, выпускаем обновления при выходе новых релизов программ 1С. Вы можете проверить разработку до покупки: сделаем бесплатный тестовый перенос из вашей базы КА 1.1 и предоставим доступ к базе-результату через веб-клиент!

29700 руб.

Кое-что простое о сложных штрих-кодах 33

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf УУ Розничная торговля Абонемент ($m) Сканер штрих-кода Бухгалтерский учет

На просторах и-нета часто встречаю публикации, в которых авторы с энтузиазмом рассказывают о том, как в штрих-код внести информацию о нескольких сущностях: например, как сделать, чтобы при сканировании одного штрих-кода на ярлыке товара, 1С определяла что это за товар, его качество и приходную накладную по которой этот товар поступил. Увы, но делается это "в лоб". Я предлагаю более разумный способ. Он очевиден - так что не претендую на лавры первооткрывателя.

1 стартмани

28.09.2018    8290    6    torch    15       

Расширение "Интерфейс Плюс" 44

Отчеты и формы Бухгалтер Пользователь Расширение (cfe) v8 v8::ОУ Розница УТ11 Россия УУ Розничная торговля Абонемент ($m) Рабочее место

Расширение для 1С:Розница 2.2 и 1С:Управление Торговлей 11, которое позволит повысить удобство работы!

3 стартмани

22.09.2018    11688    98    RocKeR_13    82       

Перенос данных УТ 10.3 => УТ 11 / КА 2 / ERP 2 (ЕРП 2) (документы, остатки и справочная информация из "1С:Управление торговлей, ред. 10.3" в УТ 11 / КА 2 / ERP 2). Обновлен до УТ 10.3.56.х, УТ 11.4.10.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Уже более 100 компаний приобрели перенос и выполнили переход на УТ 11 / КА 2 / ERP 2 с помощью нашей разработки! Обработка перехода с УТ 10.3 на УТ 11 / КА 2 / ERP 2 позволяет перенести не только остатки на указанную дату (как типовой перенос), но и все возможные документы за выбранный период. При выходе новых релизов этих программ оперативно выпускаем обновление обработки. Предоставляем техническую поддержку. Можем сделать бесплатный тестовый перенос!

29700 руб.

TextRadar - нечеткий поиск в тексте (Native API) 10

Инструменты и обработки Программист Компонента, плагин (dll, vbs,..) v8 1cv8.cf Абонемент ($m) Разработка внешних компонент

В отличие от нечеткого сравнения строк, когда обе сравниваемых строки равнозначны, в задаче нечеткого поиска выделяются строка поиска и строка данных, а вычислить необходимо не степень похожести двух строк, а степень присутствия строки поиска в строке данных. Нормированный коэффициент, находящийся между 0 и 1 позволяет отсечь заведомо низкие результаты. Наглядное отображение результатов в кратком и детальном виде поможет быстро найти интересующий фрагмент.

5 стартмани

19.09.2018    8382    15    TSSV    14       

Помощник корректировки остатков ЕГАИС в небольшом магазине. Розница 2.2 12

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Розничная торговля Абонемент ($m) Обработка документов

Данная обработка упрощает корректировку остатков алкогольной продукции небольшого магазина, где предполагается передача всей продукции в торговый зал сразу после приемки.

5 стартмани

08.09.2018    16865    78    asdfgcom    45       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Класс-обработка “Работа с картами Яндекс” 60

Инструменты и обработки Программист Конфигурация (md, cf) v8 Абонемент ($m) Разработка внешних компонент WEB

Как показать точку или маршрут на карте Яндекс. Как получить координаты по строке адреса (геокодирование).

1 стартмани

01.08.2018    12734    141    RSConsulting    13       

Распознавание лиц (off-line). Демонстрационная база. 101

Инструменты и обработки Системный администратор Пользователь Руководитель проекта Архив с данными v8 Абонемент ($m) Разработка внешних компонент

Распознавание лиц входит в нашу жизнь стремительными темпами, бизнес стремится за событиями. В публикации находится описание и пример использования нейросетей для распознавания лиц.

1 стартмани

17.07.2018    11250    74    nomadon    45       

1СПАРК РИСКИ. Сервис оценки благонадежности контрагентов. Промо

СПАРК помогает предотвратить мошенничество со стороны компаний и предпринимателей, благодаря актуальным сведениям о компаниях и системе выявления факторов риска.Сервис позволяет управлять налоговыми рисками и комплексно оценивать благонадежность контрагентов.

ЕГАИС 3 Контролёр для 1С:Розница 7

Инструменты и обработки Системный администратор Пользователь Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Android Розничная торговля Абонемент ($m) Терминал сбора данных

Оградите себя от рисков отзыва лицензии на торговлю алкоголем, штрафов и блокировок в ЕГАИС. Проверяйте поступающую алкогольную продукцию помарочно на соответствие ТТН ЕГАИС v3 перед тем, как подтвердить получение и принять её на баланс в ЕГАИС. С 01.07.2018 начинается переход ЕГАИС на помарочный учет алкогольной продукции на всех стадиях товародвижения, начиная от производства или ввоза на территорию России, до реализации в розничной торговле, т.н. "ЕГАИС 3.0". В типовой Рознице уже появилась обработка для контроля поступивших акцизных марок на ПК. Предлагаю ознакомиться с мобильным решением. Контроль производится в Android приложении на ТСД или на обычном смартфоне.

1 стартмани

13.06.2018    11003    16    kuld    30       

Пробитие чеков через ККМ в офисе (для курьеров) 12

Инструменты и обработки Пользователь Расширение (cfe) v8 v8::ОУ Розница УТ11 Россия БУ Кассовые операции Розничная торговля Абонемент ($m) ККМ Фискальный регистратор

Предлагается интеграция 1С с ККТ СтарРус. Поддерживается одновременная работа с разных рабочих мест. ККТ СтарРус работает как сервер, и принимает команды через API по http-протоколу, что позволяет пробивать чеки через центральную базу 1С для интернет-магазина и для курьеров.

1 стартмани

07.06.2018    19756    27    Kutuzov    12       

Онлайн-курс "Технология выполнения проектов ERP-класса – процессный подход". Третий поток. Курс проходит с 21 января по 18 марта 2020 года. Промо

Курс разработан Внедренческим центром «Раздолье». Курс предназначен для подготовки аналитиков, архитекторов и руководителей проектов автоматизации процессов управления с использованием комплексных ИТ-систем (1С:ERP, 1С:УХ, 1С:КА, 1С:УТ). В основе курса лежит методика применения процессного подхода.

9000 рублей

Корректировка остатков ЕГАИС для 1С:Розница/УТ 10.3 - альтернативный вариант 57

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) БУ Розничная торговля Учет ТМЦ Абонемент ($m) Обработка документов

Обработка корректировки остатков ЕГАИС для 1С Розница версии 2.2.7/2.2.8/2.2.9/2.2.10/2.2.11/УТ 10.3.47.ХХХ-48.XXX-49.XXX-50.XXX раздельно по маркируемому/немаркируемому алкоголю + создание документов постановки/списания по пересортице.

1 стартмани

02.06.2018    20136    307    independ    231       

1С:Предприятие через Интернет. 1С:Fresh Промо

Ведение бухгалтерского и налогового учет, сдача отчетности, управление бизнесом из любой точки мира. Привычные программы «1С» через Интернет без приобретения коробочных программ.

Tool1CD Beta в деле 99

Инструменты и обработки Программист Компонента, плагин (dll, vbs,..) v8 Абонемент ($m) Разработка внешних компонент

Пс, парень! Не хочешь немного сырых байтов?

1 стартмани

09.05.2018    18495    29    baton_pk    26       

Yep Cart. Пишем интернет-магазин на http-сервисах OneScript 44

Статья Программист Конфигурация (md, cf) v8 УУ Оптовая торговля Розничная торговля Абонемент ($m) OneScript

В статье описана демонстрационная конфигурация, реализующая простейший интернет магазин на http-сервисах OneScript, интегрированный с 1С:Предприятие.

1 стартмани

16.04.2018    11001    15    blackhole321    33       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Внешняя компонента для работы по Web-socket протоколу 22

Инструменты и обработки Программист Архив с данными v8 Windows Абонемент ($m) Разработка внешних компонент WEB

Кто когда-нибудь сталкивался с обменом данными по Web-Socket (wss) протоколу из 1С, тому известно, что в платформе отсутствуют данные механизмы (не путать с HTTP запросами и WebServices). Предлагается использовать внешнюю компоненту, написанную по технологии NativeAPI, для подключения и обмена с серверами из 1С-Предприятия, работающими по протоколу Web-Socket.

5 стартмани

30.03.2018    14678    9    Ditron    63