Использование регулярных выражений (RegExp) в 1С8.х

Публикация № 64222

Разработка - Практика программирования

1. Использование
2. Достоинства RegExp
3. Отладка и проверка (RegExBuddy)
4. "Обертки"
5. Примеры использования (полезные универсальные функции)
6. Заключение

Данный материал касается платформы 8.х

О функциях и формате шаблона RegExp подробно можно почитать здесь:
http://ru.wikipedia.org/wiki/Регулярные_выражения
http://www.script-coding.info/WSH/RegExp.html
Книга Михайлов А. Системное программирование в 1С: Предприятии 7.7/8.0 (Глава 1. "Применение технологий СОМ и ActiveX" - "Регулярные выражения")

библиотека RegExp является предустановленной т.е. есть в любом Windows

 

Возможности регулярных выражений:
Сравнить текст с заданным шаблоном (метод Test).
Заменить или удалить из  строки текст, соответствующий заданному шаблону (метод Replace).
Извлечь из строки текст, соответствующий заданному шаблону (метод Execute).

1. Использование 

RegExp используется в 1С через COM интерфейс пример кода:

RegExp = Новый COMОбъект("VBScript.RegExp");// создаем объект для работы с регулярными выражениями
RegExp.MultiLine = Истина;  // истина — текст многострочный, ложь — одна строка
RegExp.Global = Истина;     // истина — поиск по всей строке, ложь — до первого совпадения
RegExp.IgnoreCase = Истина; // истина — игнорировать регистр строки при поиске

Шаблон = ".+@.+\..+"; //шаблон проверки e-mail

RegExp.Pattern = Шаблон;    // шаблон (регулярное выражение)

ПроверяемыйEMail = "test@mail.ru";

Если Не
RegExp.Test(ПроверяемыйEMail) Тогда
   
Сообщить("Некорректный email");
КонецЕсли;

о методах и свойствах можно почитать подробно здесь

2. Достоинства RegExp

Плюсы:

  • хорошая скорость анализа т.к. 1С анализ строк (разбор) обычно реализуется циклами и функциями: Лев, Прав, Сред, Найти, а встроенный язык медленный
  • высокая читаемость и модифицированность (более предсказуем в случае несоответствия строки - разбору)
  • доп. функционал (можно осуществлять анализ, замену и проверку строковых выражений)

Минусы:

  • не все задачи можно решить (например рекурсивные разборы тип 1 + (2+3*(2-7)) в случае если нужно разобрать на выражения в скобках) приходится смешивать с кодом
  • Возможны зависания при использовании сложных шаблонов. Отладчик RegExBuddy в таких ситуациях пишет о невозможности получить результат за разумное число итераций
  • RegExp доп. библиотека (инициализация занимает значительное время)

  основное достоинство RegExp это читаемость

3. Отладка и проверка (RegExBuddy) 

Отладка регулярных выражений довольно частая задача т.к. бывает трудно понять и сам шаблон и ошибки в разборе. Наиболее удобным инструментом на мой взгляд является программа RegexBuddy (внешний вид программы есть в скриншотах) она осуществляет подцветку разбираемых выражений и многое другое, есть все что нужно и даже больше. Очень простой в использовании инструмент.

Также есть тестер 8.1 от coder1cv8, но в нем к сожалению нет подвыражений и запускается только из 1С8.

4. "Обертки"

При частом использовании RegExp приходится делать более удобные и читаемые "оберки" (+ русифицированные) Внимание! Данные функции более медленные

Код функций:

Перем RegExp;

//RegExp --------------------------------------------------------

Процедура РегулярныеВыражения_Инициализация (Шаблон, ИскатьДоПервогоСовпадения = Истина, МногоСтрок = Истина, ИгнорироватьРегистр = Истина) Экспорт

    Если
RegExp = Неопределено Тогда //Нужна инициализация
       
RegExp = Новый COMОбъект("VBScript.RegExp");    // создаем объект для работы с регулярными выражениями
   
КонецЕсли;

   
//Заполняем данные
   
RegExp.MultiLine = МногоСтрок;                  // истина — текст многострочный, ложь — одна строка
   
RegExp.Global = Не ИскатьДоПервогоСовпадения;   // истина — поиск по всей строке, ложь — до первого совпадения
   
RegExp.IgnoreCase = ИгнорироватьРегистр;        // истина — игнорировать регистр строки при поиске
   
RegExp.Pattern = Шаблон;                        // шаблон (регулярное выражение)

КонецПроцедуры

Функция
РегулярныеВыражения_Проверка(ПроверяемыйТекст)

    Возврат
RegExp.Test(ПроверяемыйТекст);

КонецФункции

Функция РегулярныеВыражения_Выполнить(АнализируемыйТекст) Экспорт

   
РезультатАнализаСтроки = RegExp.Execute(АнализируемыйТекст);

   
МассивВыражений = Новый Массив;

    Для Каждого
Выражение Из РезультатАнализаСтроки Цикл
       
СтруктураВыражение = Новый Структура ("Начало, Длина, Значение, ПодВыражения", Выражение.FirstIndex, Выражение.Length,Выражение.Value);

       
//Обработка подвыражений
       
МассивПодВыражений = Новый Массив;
        Для Каждого
ПодВыражение Из Выражение.SubMatches Цикл
           
МассивПодВыражений.Добавить(ПодВыражение);
        КонецЦикла;
       
СтруктураВыражение.ПодВыражения = МассивПодВыражений;

       
МассивВыражений.Добавить (СтруктураВыражение);

    КонецЦикла;

    Возврат
МассивВыражений;

КонецФункции

//RegExp --------------------------------------------------------

 

Использование  на примере с email:

РегулярныеВыражения_Инициализация (".+@.+\..+");

ПроверяемыйEMail = "test@mail.ru";
Если Не
РегулярныеВыражения_Проверка(ПроверяемыйEMail) Тогда
   
Сообщить("Некорректный email");
КонецЕсли;

5. Примеры использования (полезные универсальные функции)

Функция ПодставитьПараметрыВСтроку (СтрокаШаблон, Коллекция) - подставляет в строку параметры из коллекции

   СтрокаШаблон - строка вида "Текст [Параметр]" параметры должны быть заключены в квадратные скобки

   Коллекция - коллекция из которой будут подбираться одноименные параметры

Пример: ПодставитьПараметрыВСтроку ("Выполнено: [ВыполненоПроцент]%", Новый Структура ("ВыполненоПроцент",50));

Результатом выполнения будет строка : "Выполнено: 50%"


Функция РазложитьСтрокуВМассив (Строка, Разделитель = ",") - возвращает массив полученный из строки  элементами которого являются строки разделенные разделителем (эта функция есть практически в любой конфигурации от  1С)

  Строка - строка из которой берем данные

  Разделитель -  символ разделитель (по умолчанию ",")

Пример: РазложитьСтрокуВМассив("1,23,45");

Результатом выполнения будет массив строк : "1","23","45"


Код функций:

Функция ПодставитьПараметрыВСтроку (Шаблон, КоллекцияЗаполнения) Экспорт

   
РегулярныеВыражения_Инициализация ("\[([\d\wЁА-Я]+)\]", Ложь);
   
НайденныеПараметры = РегулярныеВыражения_Выполнить(Шаблон);

   
НовыйТекст = Шаблон;

    Для Каждого
Параметр Из НайденныеПараметры Цикл

       
//Получим имя параметра
       
ИмяПараметра = Параметр.ПодВыражения[0];//Первый элемент

       
Попытка //Параметр может отсутствовать в коллекции
            //Получим значение параметра
           
ЗначениеПараметра = КоллекцияЗаполнения[ИмяПараметра];

           
//Подстановка параметров
           
НовыйТекст = СтрЗаменить(НовыйТекст, Параметр.Значение, ЗначениеПараметра);
        Исключение
        КонецПопытки;

    КонецЦикла;

    Возврат
НовыйТекст;

КонецФункции

Функция РазложитьСтрокуВМассив(Строка, Разделитель = ",") Экспорт

   
//Разбор строки вида 1,СЛОВО,(1+2); Маска для разделителя ',' ([^\,]+),?"
   
РегулярныеВыражения_Инициализация ("[^\" + Разделитель + "]+", Ложь, Ложь, Ложь);
   
Выражения = РегулярныеВыражения_Выполнить(Строка);

   
Массив = Новый Массив;

    Для Каждого
Выражение Из Выражения Цикл
       
Массив.Добавить(Выражение.Value);
    КонецЦикла;

    Возврат
Массив;

КонецФункции

 

Можно было привести более сложные примеры, но они бы имели узкую направленность.

6. Заключение

RegExp имеет хорошую скорость обработки и отличную читаемость .

На регулярах построены многие интересные разработки на инфостарте:

Разукрашка (1.4.1.5) alexk-is

Раскрашивание текста запроса 

[2 in 1] «Обфускация кода 1С» и «RegExp Тестер» от coder1c8

т.е. везде где нужна низкоуровневая обработка текста (разбор различных текстовых данных) хороший выбор это регуляры.

в файлах есть пример кода на RegExp и сравнение скорости

 

Скачать файлы

Наименование Файл Версия Размер
Пример 8.1. Тест. Сравнение скорости RegExp и встроенного языка на функции разбора 1,2,3
.epf 8,11Kb
27.01.10
344
.epf 8,11Kb 344 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Арчибальд 2708 25.01.10 19:15 Сейчас в теме
2. Душелов 25.01.10 19:24 Сейчас в теме
3. Saint 16 25.01.10 20:33 Сейчас в теме
Хорошая статья. Единственное дополнение: при реальном использовании обёрток возможно более удобным будет оформить их в отдельном общем модуле. Типа эмуляция класса. :D
sogesti; Evg-Lylyk; +2 Ответить
4. Evg-Lylyk 2764 25.01.10 20:44 Сейчас в теме
(3) Спасибо. Надо подумать как это поудобнее оформить.
5. awk 694 25.01.10 20:52 Сейчас в теме
(0) Жаль в VBS регулярные выражения кастрированы...
6. Душелов 25.01.10 22:09 Сейчас в теме
(5) Я свою компоненту набросал для использования нетовских регулярных выражений из 1с-ки.
7. Evg-Lylyk 2764 25.01.10 22:16 Сейчас в теме
8. Душелов 25.01.10 23:03 Сейчас в теме
(7) У меня НЕТ везде стоит, так что на счет этого не беспокоюсь вообще.
9. Evg-Lylyk 2764 25.01.10 23:22 Сейчас в теме
(8) меня больше беспокоит где он не стоит :D
10. tormozit 5667 26.01.10 08:39 Сейчас в теме
Из минусов обязательно нужно упомянуть возможность зависания при использовании сложных шаблонов. Отладчик RegExBuddy в таких ситуациях пишет о невозможности получить результат за разумное число итераций.
Evg-Lylyk; +1 Ответить
14. Evg-Lylyk 2764 26.01.10 12:30 Сейчас в теме
(10) Хорошо... я с подобным не сталкивался. Здорово если бы был примерчик такого шаблона с которым зависает
(11) Если хорошо поискать можно найти и "русскую версию" ;)
(12) По сравнению со встроенным языком это как мне кажется не ограниченность
Было бы здорово если бы 1С встроила поддержу RegExp на уровне платформы наконец то за код Лев(Стр,Найти(... можно будет проклинать :)
11. Stepa86 1307 26.01.10 08:54 Сейчас в теме
12. coder1cv8 3462 26.01.10 09:34 Сейчас в теме
А где книжечку с "обложки" публикации скачать можно? :)

Из минусов я бы отметил еще ограниченность регэкспов в VBS (тут об этом уже упоминалось), нет "просмотра назад" в частности, что меня очень огорчило, когда я писал свой обфускатор...
13. Totoro 550 26.01.10 10:24 Сейчас в теме
(0) Доступно и понятно. Молодец.
(12) Например на Infanata
15. aipnnov 163 26.01.10 14:29 Сейчас в теме
Очень хорошо написано и понятно.
16. alexk-is 6433 26.01.10 18:03 Сейчас в теме
Скачал. Запустил. Получил:
Выполнений: 100 функций на RegExp время: 172 мс
Выполнений: 100 Функции из Бух 1.6 и КОРП 2.0 время: 78 мс

Мне показалось, что должно быть наоборот. Что я делаю не так?
Прикрепленные файлы:
17. Душелов 26.01.10 18:09 Сейчас в теме
(16) Думаю, что из теста времени надо убрать время на создание ком-объекта.
18. alexk-is 6433 26.01.10 18:25 Сейчас в теме
(17) Ком-объект создается и настраивается при открытии обработки в её модуле. Проверил в отладчике - отрабатывается 1 раз при открытии...

Думал время определяет неправильно. Добавил циклов. Получил:
Выполнений: 1 000 функций на RegExp время: 1 781 мс
Выполнений: 1 000 Функции из Бух 1.6 и КОРП 2.0 время: 703 мс
19. Душелов 26.01.10 18:33 Сейчас в теме
(18) А что за обработка? Дай посмотреть ;)
20. alexk-is 6433 26.01.10 18:38 Сейчас в теме
(19) Вверху страницы "Скачать Пример. Тест. Сравнение скорости..."
21. alexk-is 6433 26.01.10 18:48 Сейчас в теме
+18 Думал из-за конфигурации. Запустил в УПП. Получил:
Выполнений: 1 000 функций на RegExp время: 1 719 мс
Выполнений: 1 000 Функции из Бух 1.6 и КОРП 2.0 время: 625 мс
22. Душелов 26.01.10 18:59 Сейчас в теме
Выполнений: 100 функций на RegExp время: 445 мс
Выполнений: 100 Функции из Бух 1.6 и КОРП 2.0 время: 341 мс
23. alexk-is 6433 26.01.10 19:18 Сейчас в теме
(22) Ну, вот. Хоть и не большой, а перевес в сторону 1С. :(
Видимо у меня ПК немного побыстрее и 1С отрабатывает на нем оптимальнее чем RegExp.
24. Душелов 26.01.10 19:23 Сейчас в теме
(23) А мне кажется, что тут дело в кэшировании... Надо бы тест переделать на рандомную последовательность разбираемой строки...
25. alexk-is 6433 26.01.10 19:41 Сейчас в теме
(24) Вряд ли. В функции 1С строка постоянно режется и результат пишется в ту же переменную. Так не прокэшировать.

Но как вариант можно попробовать и случайный набор строк.
27. Душелов 26.01.10 21:15 Сейчас в теме
(25) Все таки, думаю, при постоянном вычислении одних и тех же значений 1С-как кэширует.

И я ряд тестов провел, скорость примерно одинаковая, выше/ниже друг друга.

Согласен с (26) надо более сложный пример.
26. Evg-Lylyk 2764 26.01.10 20:26 Сейчас в теме
(24), (25) неудачный пример для сравнения получился (слишком простой) поэтому и не акцентировал на нем внимание.
На моей системе выдавал как у Душелова около 400 мс иногда с перевесом в пользу 1С.
Я уже давно сталкивался что 1С быстрее отрабатывает на простых вариантах, поэтому и писал про читаемость

Душелов; +1 Ответить
28. alexk-is 6433 26.01.10 21:30 Сейчас в теме
(26) (27) Я "ЗА" тестирование. Но у меня нет более сложного примера. Что вы имеете ввиду?

А функция в 1С могла бы выглядеть так:
Функция РазложитьСтрокуВМассивПодстрокБух16Корп20(Знач Стр, Разделитель = ",") Экспорт
	МассивСтрок = Новый Массив;
	ДлинаРазделителя = СтрДлина(Разделитель);
	Поз = Найти(Стр, Разделитель);
	Пока Поз <> 0 Цикл
		МассивСтрок.Добавить(Лев(Стр, Поз - 1));
		Стр = Сред(Стр, Поз + ДлинаРазделителя);
		Поз = Найти(Стр, Разделитель)
	КонецЦикла;
	МассивСтрок.Добавить(Стр);
	Возврат МассивСтрок
КонецФункции // глРазложить
Показать

Мне кажется вполне читаемо и работает быстрее. Возможно на более сложном примере будет иначе...
29. Душелов 26.01.10 22:01 Сейчас в теме
(28) Берем к примеру любой анализ хтмл-кода, к примеру, выбрать весь текст, без тегов и т.п. Думаю, что "в ручном" режиме 1С это будет делать очень долго, именно в этом и есть прелесть регулярных выражений.
Или отобрать все е-мыл адреса в тексте.... Примеров найти можно много, но тут сложность будет в другом - написать аналогичные примеры на языке 1С.
30. Evg-Lylyk 2764 26.01.10 23:05 Сейчас в теме
(28) если честно я редко заморачиваюсь на счет скорости в абсолютном виде. Приемлемая вот то слово.
(29) согласен правильные примеры
Найти все GUIDы в тексте

Главная прелесть регуляров то что анализ описывается простым понятным языком.
Мое знакомство с RegExp началось когда мне нужно было разбирать файлы от дистрибьюторов вида:

<RCAgent {1},{Иванов}>
<SalesMen {1}, {ТП}, {1}>
...

причем была обработка, которая обрабатывала файлы, но она делала это очень медленно на файлы 30 Кб уходило по 5 минут. Понятно что она была написана не оптимально, но мне если честно трудно упрекать автора т.к. у меня от многих задач разбора текста "голова съезжала".
Переписал на RegExp оказалось просто и понятно и даже оптимизировать не пришлось разбор файлов по 100 Кб стал занимать 10 сек вместе с записью данных в СУБД. Было правда несколько ошибок, но это из за моего плохого знания языка шаблонов, да и ошибки исправлялись за 1 минуту.
35. artbear 1171 27.01.10 18:07 Сейчас в теме
(28) Приведенного кода из (34) достаточно для сравнения производительности и тестирования ? :)
31. Dementor 625 27.01.10 10:32 Сейчас в теме
Очень хороший обзор. За примеры кода - отдельное спасибо.
На скоростях не замарачивайтесь - можеть и дольше чем на встроенном языке 1С, но зато понятность и скорость алгоритмизации процеса это компенсирует.
Evg-Lylyk; +1 Ответить
32. artbear 1171 27.01.10 15:58 Сейчас в теме
Да, хороший обзор.
Лично я бы код функций оформил по-другому:
1. простой общий модуль - в каждую функции передаем переменную RegExp как первый параметр
т.е. сначала создаем (кеширование), затем используем
в этом случае можно сделать проверку параметра в каждой функции - типа если параметр не заполнен, то создаем его по новой, если заполнен, пропускаем.

2. или создаем отдельную обработку-класс, в модуль которой и записываем весь указанный код, убираем из имен функций строку "РегулярныеВыражения_", добавляем к нужным функциям Экспорт.
и класс почти спокойно можно юзать.

Лично мне как приверженцу ООП нравится второй вариант :)

Ну и пример на самом деле хорошо бы поменять :)
33. artbear 1171 27.01.10 16:47 Сейчас в теме
РазложитьСтрокуВМассив и ПодставитьПараметрыВСтроку нужно изменить, т.к они могут работать неточно :)
например, в первый метод передадим в качестве разделителя точку, получим ошибки :)
во втором также могут быть проблемы - название функции не очень соответствует выполняемой функции
38. Evg-Lylyk 2764 27.01.10 20:39 Сейчас в теме
(33) с разделителем точка не будет проблем проверил шаблон "[^\.]*"
(34) спасибо теперь лучше ;)
(36) класс!!! будем знать самый быстрый вариант

Учел ценные предложения товарища artbear (обновил пример)
34. artbear 1171 27.01.10 17:03 Сейчас в теме
Насчет примера был неправ.
Даже в этом случае регулярные выражения немного, но выигрывают.
Проблема просто в неоптимальном/неаккуратном коде реализации метода РазложитьСтрокуВМассив :)
вместо вычисляющего цикла
Код
Для Сч = 0 По Matches.Count - 1 Цикл
      Массив.Добавить(Matches.Item(Сч).Value);
   КонецЦикла;
Показать полностью

нужно юзать простое
Код
Для каждого Item Из Matches Цикл
      Массив.Добавить(Item.Value);
   КонецЦикла;
Показать полностью

и результат налицо:
Выполнений: 1 000 функций на RegExp время: 2 516 мс
Выполнений: 1 000 Функции из Бух 1.6 и КОРП 2.0 время: 2 906 мс

для 100 функций - время одинаково :)

и это на очень простой задаче :) - а на сложных выигрыш будет намного больше

ЗЫ жаль, что код
Код
КОМ_Массив = Новый COMSafeArray(Matches);
   КОМ_Массив.Выгрузить(Массив);
Показать полностью

не работает, так было бы еще быстрее :)

PPS естественно, код функции РегулярныеВыражения_Выполнить также нужно изменить.
Evg-Lylyk; +1 Ответить
36. Душелов 27.01.10 18:31 Сейчас в теме
(34) :)

А круче всех в этом сравнении:

Функция РазложитьСтрокуВМассивЯва(Строка, Разделитель = ",") Экспорт
	Массив = Script.eval("
	|var str=""" + Строка + """;
	|str.split(""" + Разделитель + """);");
	
	Возврат Массив;
КонецФункции
Evg-Lylyk; +1 1 Ответить
40. artbear 1171 28.01.10 07:45 Сейчас в теме
(36) Код на Яве не соответствует требованиям теста - возвращаемое значение не Массив 1С :)
нужно в ее конце вставить код
Код
   резМассив = Новый Массив;
   Для каждого Item Из Массив Цикл резМассив.Добавить(Item); КонецЦикла;
      
   Возврат резМассив;
Показать полностью

И результат по тесту из (39)
Выполнений: 1 000 Функции из Бух 1.6 и КОРП 2.0 время: 797 мс
Выполнений: 1 000 функций на RegExp время: 1 296 мс
Выполнений: 1 000 функций на Ява время: 2 063 мс

Счас посмотрю код 1С из (39)

ЗЫ лично я для проверки в конце модуля формы сразу вставляю юнит-тест, который и выдал мне ошибку для Явы :)
Код
   // -- Артур -- 28.01.2010
   артТесты.ПроверитьРавенство(АнализТекстаЗапроса_МАССИВ_ОПЕРАТОРОВ_1.Количество(), АнализТекстаЗапроса_МАССИВ_ОПЕРАТОРОВ_2.Количество(), "массивы операторов 1 и 2");
   артТесты.ПроверитьРавенство(АнализТекстаЗапроса_МАССИВ_ОПЕРАТОРОВ_1.Количество(), АнализТекстаЗапроса_МАССИВ_ОПЕРАТОРОВ_3.Количество(), "массивы операторов 1 и 3");
   
   артТесты.ПроверитьРавенство(АнализТекстаЗапроса_МАССИВ_ФУНКЦИЙ_1.Количество(), АнализТекстаЗапроса_МАССИВ_ФУНКЦИЙ_2.Количество(), "массивы функций 1 и 2");
   артТесты.ПроверитьРавенство(АнализТекстаЗапроса_МАССИВ_ФУНКЦИЙ_1.Количество(), АнализТекстаЗапроса_МАССИВ_ФУНКЦИЙ_3.Количество(), "массивы функций 1 и 3");
   // --завершение
Показать полностью


и сплю спокойно
37. Душелов 27.01.10 18:39 Сейчас в теме
Выполнений: 100 Функции из Бух 1.6 и КОРП 2.0 время: 439 мс
Выполнений: 100 функций на RegExp время: 334 мс
Выполнений: 100 функций на яве время: 224 мс
39. alexk-is 6433 28.01.10 06:55 Сейчас в теме
1С интерпретатор. Больше строк кода - медленнее работает. Внес изменения в тест. Тест прилагается.

Выполнений: 1 000 Функции из Бух 1.6 и КОРП 2.0 время: 641 мс
Выполнений: 1 000 функций на RegExp время: 1 047 мс
Выполнений: 1 000 функций на Ява время: 843 мс

Нужно еще подумать... :)
Прикрепленные файлы:
Тест2.epf
41. artbear 1171 28.01.10 07:49 Сейчас в теме
ОФФ. По (39) мелкий коммент -
ИМХО очень неудачное структурирование кода в одну строку :(
читать очень трудно, почти невозможно :(
особенно метод РазложитьСтрокуВМассивПодстрокБух16Корп20
остальные-то более тривиальны.
43. alexk-is 6433 28.01.10 08:10 Сейчас в теме
(41) Структурированный код приведен в (28), а в тексте теста используется оптимизированный код. :)
В 1 строчку работает в 1.5-2 раза быстрее. О причинах я писал в (39) - 1С интерпретатор.
44. artbear 1171 28.01.10 08:53 Сейчас в теме
(43) Про скорость кода в 1 строку согласен
(42) (43)
Можно еще ускорить :)
1. в конце модуля добавляем
Код
резМассив = Новый Массив;
Script.AddObject("myarray", резМассив);
Показать полностью


2. исправляем метод РазложитьСтрокуВМассивЯва
на следующий
Код
Функция РазложитьСтрокуВМассивЯва(Строка, Разделитель = ",") Экспорт 
   резМассив.Очистить();
   резМассив = Script.eval("var str=""" + Строка + """; array1 = str.split(""" + Разделитель + """); for (i = 0; i < array1.length; i++) { myarray.Add(array1[i]); }; myarray; "); Возврат резМассив;
КонецФункции
Показать полностью


Получаем результат
Выполнений: 1 000 Функции из Бух 1.6 и КОРП 2.0 время: 735 мс
Выполнений: 1 000 функций на RegExp время: 1 859 мс
Выполнений: 1 000 функций на Ява время: 688 мс

счас переделаю код RegExp :)

PS юнит-тесты показывают, что код верный - возвращается правильный массив
kote; json; Душелов; +3 Ответить
45. Душелов 28.01.10 09:21 Сейчас в теме
(44) Нормально!.. Можно еще поковырять :)
47. artbear 1171 28.01.10 09:31 Сейчас в теме
(45) На самом деле я немного смухлевал, конечно :)
Ведь в (44) на самом деле для Явы всегда возвращается один и тот же массив :( - а в остальных всегда вновь созданный.
К сожалению, у 1С нет метода копирования одного массива в другого или хотя бы конструирования массива по другому массиву.
А выгрузка/загрузка через списокЗначений или таблицуЗначений сильно тормозит :( (фактически время увеличивается в 2 раза)

Остается утешаться тем, что для более сложных задач RegExp поудобнее/помощнее/поудобнее :)
46. alexk-is 6433 28.01.10 09:29 Сейчас в теме
(44) Ошибочка :)

Выполнений: 1 000 Функции из Бух 1.6 и КОРП 2.0 время: 641 мс
Количество элементов: 151
Выполнений: 1 000 функций на RegExp время: 1 047 мс
Количество элементов: 151
Выполнений: 1 000 функций на Ява время: 797 мс
Количество элементов: 302 000
Прикрепленные файлы:
Тест2.epf
48. artbear 1171 28.01.10 09:32 Сейчас в теме
(46) Забыл дописать - естественно, в функции Ява нужно добавить резМассив.Очистить() :)

У меня юнит-тесты все равно такую ошибку бы не пропустили :)
49. artbear 1171 28.01.10 10:08 Сейчас в теме
(46) (45) Еще поковырял код :)
Выполнений: 1 000 Функции из Бух 1.6 и КОРП 2.0 время: 750 мс
Выполнений: 1 000 функций на RegExp время: 1 844 мс
Выполнений: 1 000 функций на Ява время: 344 мс

Вместо Явы, которая не возвращает чистый SafeArray, использую VBScript
в начале модуля
Код
Перем Script2;

Функция РазложитьСтрокуВМассивЯва(Строка, Разделитель = ",") Экспорт 
   Возврат Script2.eval("Split(""" + Строка + """, """ + Разделитель + """)").Выгрузить();
КонецФункции
Показать полностью

и в конце модуля
Код
Script2 = Новый COMОбъект("MSScriptControl.ScriptControl");
Script2.Language = "vbscript";
Показать полностью


ЗЫ код 1С также в 1 строчку.
Прикрепленные файлы:
Тест2.epf
50. Душелов 28.01.10 10:17 Сейчас в теме
(49) Это не ява, это VBS :) добавляй в тест ;)
42. Душелов 28.01.10 08:05 Сейчас в теме
Все таки примеры нужны другие :)
Типа тех, что я предложил ниже.
51. artbear 1171 28.01.10 11:51 Сейчас в теме
Итак, для простой задачи получения массива подстрок из строки по разделителю
получилось вот такое распределение
Выполнений: 1 000 Функции из Бух 1.6 и КОРП 2.0 время: 750 мс
Выполнений: 1 000 функций на RegExp время: 969 мс
Выполнений: 1 000 функций на VBScript время: 375 мс

Больше способа ускорить получение данных через RegExp не нашел.
Уже видно, что не такая большая разница между 1С и RegExp - даже для столь простой задачи.

Ну и ВБСкрипт выше всяких похвал :)

ЗЫ в последнем варианте реализации regExp загнал практически весь код в ВБСкрипт.
Прикрепленные файлы:
Тест2.epf
52. alexk-is 6433 28.01.10 12:09 Сейчас в теме
(51) Сделал более "читаемый" текст модуля на 1С. Вот результаты замеров.

Выполнений: 100 Функции из Бух 1.6 и КОРП 2.0 время: 47 мс
Выполнений: 100 функций на RegExp время: 78 мс
Выполнений: 100 функций на VBScript время: 47 мс

Выполнений: 1 000 Функции из Бух 1.6 и КОРП 2.0 время: 469 мс
Выполнений: 1 000 функций на RegExp время: 890 мс
Выполнений: 1 000 функций на VBScript время: 406 мс
Прикрепленные файлы:
Тест2.epf
53. Душелов 28.01.10 12:25 Сейчас в теме
А вот альтернативные способы получить на 1С-е, не такие быстрые...

Строка = СтрЗаменить(Стр, Разделитель, Символы.ПС);
Для сч = 1 По СтрЧислоСтрок(Строка) Цикл
	МассивСтрок.Добавить(СтрПолучитьСтроку(Строка, сч));
КонецЦикла;


или, где Т = Новый ТекстовыйДокумент;

Строка = СтрЗаменить(Стр, Разделитель, Символы.ПС);	
Т.УстановитьТекст(Строка);
Для сч = 1 По Т.КоличествоСтрок() Цикл
	МассивСтрок.Добавить(Т.ПолучитьСтроку(сч));
КонецЦикла;
54. alexk-is 6433 28.01.10 12:53 Сейчас в теме
(53) Вот и я говорю об альтернативном коде и довольно быстром...
Возврат ЗначениеИзСтрокиВнутр("{""#"",51e7a0d2-530b-11d4-b98a-008048da3034,{0,{""S"",""" + СтрЗаменить(Стр, Разделитель, """},{""S"",""") + """}}}")
55. artbear 1171 28.01.10 13:30 Сейчас в теме
(54) Интересный вариант :)

А почему у тебя в (52) разница не такая большая ?
у меня на твоем тесте
Выполнений: 1 000 Функции из Бух 1.6 и КОРП 2.0 время: 625 мс
Выполнений: 1 000 функций на RegExp время: 1 000 мс
Выполнений: 1 000 функций на VBScript время: 407 мс

т.е. ЗначениеИзСтрокиВнутр и рядом с ВБ не стоит :)
56. alexk-is 6433 28.01.10 13:41 Сейчас в теме
(55) Наверное зависит от ПК, ОС и другого установленного ПО. У меня дома почему-то 1С немного медленее шевелится, хотя ПК почти одинаковые (дома RAID побольше :) ).
57. artbear 1171 28.01.10 13:49 Сейчас в теме
(56) Кстати, меня давно интересует вопрос - почему 1С функцию РазложитьСтрокуВМассив не реализует как встроенную/штатную.
Ведь у 1С на этой функции достаточно много построено :)

Кстати, твой код в (52) уже не имеет никакого отношения к Бух 1.6 и КОРП 2.0 :)
60. alexk-is 6433 28.01.10 14:18 Сейчас в теме
(57) Функция ЗначениеЗаполнено() появилась тоже сравнительно недавно. Может быть в 8.3 сделают. :)

В 7.7 у меня все построено на списках значений (динамических массивов нет) и используется приблизительно вот такой код:
СЗ = СоздатьОбъект("СписокЗначений");
СЗ.ИзСтрокиСРазделителями("""" + СтрЗаменить(ИсходнаяСтрока, Разделитель, """,""") + """");
Возврат СЗ;
Т.е. кое что по разбору строк в списки раньше было, но со временем об этом забыли...

Кстати, твой код в (52) уже не имеет никакого отношения к Бух 1.6 и КОРП 2.0
Ну, я тоже к этому не имею непосредственного отношения :)
61. artbear 1171 28.01.10 15:38 Сейчас в теме
(60) это уже ОФФ :)
В 77 нужно хотя бы просто загружать ВК 1С++ - создание объектов будет супербыстрым, в штатной 1С оно очень-очень медленно.
Лично проверял и делал код в 1С++ :)
58. Душелов 28.01.10 14:07 Сейчас в теме
Я думаю, что надо заводить отдельную ветку с поисками и оптимизацией алгоритмов штатных, 1С-ных универсальных методов.
Evg-Lylyk; artbear; +2 Ответить
59. artbear 1171 28.01.10 14:14 Сейчас в теме
(58) Хорошая идея.
Завел новую ветку
http://infostart.ru/public/64770/
Evg-Lylyk; +1 Ответить
62. alexk-is 6433 31.01.10 13:03 Сейчас в теме
(0) Предполагаю, что в п. 6. Заключение есть ссылка на меня. Можно поправить ник или это так задумано?
63. Evg-Lylyk 2764 31.01.10 13:06 Сейчас в теме
64. TUTSIC9 21.09.11 12:46 Сейчас в теме
Суперски!!! Регулярные выражения очень помогаюТ!!! не Хочется каждый раз писать одно и тоже )
Evg-Lylyk; +1 Ответить
65. CaSH_2004 355 28.10.11 22:20 Сейчас в теме
Автор - СПАСИБО за подробное изложение!
66. bar_s 20.11.11 16:25 Сейчас в теме
Выполнений: 100 Функции из Бух 1.6 и КОРП 2.0 время: 47 мс
Выполнений: 100 функций на RegExp время: 78 мс
Выполнений: 100 функций на VBScript время: 47 мс

Выполнений: 1 000 Функции из Бух 1.6 и КОРП 2.0 время: 469 мс
Выполнений: 1 000 функций на RegExp время: 890 мс
Выполнений: 1 000 функций на VBScript время: 406 мс
67. fixin 3899 12.12.11 11:08 Сейчас в теме
хорошая статья, жаль нет примеров, как заменить одну строку на другую, но буду копать.

Может быть на РегЭксп так долго, потому что каждый раз объект создаете? Попробуйте его один раз создавать.

Ссылка http://www.script-coding.info/WSH/RegExp.html битая...
Вместо нее рекомендую: http://www.script-coding.com/WSH/RegExp.html#3.1.
68. ADirks 181 12.04.13 10:27 Сейчас в теме
С фразы: "основное достоинство RegExp это читаемость"
чуть со стула не упал :)
например, чё за? '^\\s*((?:(?:(?:"[^"]")*)|(?:[^/]*)|(?:[^/]+/))*)(//.*)?\\s*$'
и это ведь достаточно примитивный RegExp

Ну и за [([\wА-яёЁ]+)\] хочется кого-то придушить. Почему в Perl'е я могу просто написать \w, а в родном виндовом движке - фигушки??!!!
69. Evg-Lylyk 2764 12.04.13 18:16 Сейчас в теме
(68) Читаемость относительная. Код еще сложнее. Ну естественно при условии хороших знаний регуляров
70. ADirks 181 12.04.13 18:36 Сейчас в теме
(69) Основной прикол регэкспов в том, что написать иной раз проще, чем понять :)
77. andrewks 1274 01.01.14 23:02 Сейчас в теме
(70)

Some people, when confronted with a problem, think
“I know, I'll use regular expressions.” Now they have two problems.
©
71. Tedman 14.11.13 10:37 Сейчас в теме
Если я всё правильно понимаю, то можно и не спрашивать будет ли конструкция
Новый COMОбъект("VBScript.RegExp");

у меня работать, если сервер 1С располагается на Linux?
72. Evg-Lylyk 2764 14.11.13 10:47 Сейчас в теме
(71) Ну да не будет
Там наверно есть другие библиотеки, но подсказать ничего не могу.
73. Tedman 14.11.13 11:18 Сейчас в теме
(72) Ну да, там есть штатные консольные средства мощные. Ясненько... просто решил уточнить. Спасибо.
74. Jon2011 77 29.11.13 11:03 Сейчас в теме
Всем привет! Есть обработка по поиску картинок в интернете: http://infostart.ru/public/82682/
в ней как раз основная фишка поиск через регулярное выражение.
Алгоритм простой: из Гугля или Яндекса получаем список картинок и анализируем при помощи регулярного выражения
мRegExp.Pattern = "imgres\?imgurl=(.*?)&imgrefurl=(.*?)&usg.*?&h=(.*?)&w=(.*?)&sz=(.*?)&.*?;tbnid=(.*?):";

Если Matches.Count больше нуля - все ОК.
Все работало хорошо до последнего времени, что сломалось не пойму.
Гугл картинки собирает, а скрипт ничего найти не может. Может кто знает в чем проблема?

P.S. Автор разработки отмалчивается.
75. d_vit 26 04.12.13 11:15 Сейчас в теме
(74)Присоединяюсь.
Помогите пожалуйста с решением данной проблемы.
76. GreenLab 77 01.01.14 21:23 Сейчас в теме
У кого-нибудь работает под 8.3.4. ?
При подключении компоненты под 8.3.4.389 падает платформа.
78. andrewks 1274 01.01.14 23:05 Сейчас в теме
79. GreenLab 77 02.01.14 09:35 Сейчас в теме
(78) andrewks, О сорри, не в ту публикацию написал. Падает под 8.3.4 именно компонента от Орефкова


80. LOleg 03.03.16 12:28 Сейчас в теме
вот это да, это же джаваскрипт в 1С :)
Оставьте свое сообщение

См. также

Краткое руководство по внесению изменений в конфигурацию

Статья Программист Нет файла v8 1cv8.cf Абонемент ($m) Практика программирования

Кратко описаны основополагающие моменты при старте групповой разработки конфигурации несколькими программистами. Полезно для проектной документации как требование к разработчикам или сопровождающей компании.

1 стартмани

13.01.2020    5102    12    sapervodichka    34       

INFOSTART MEETUP Krasnodar. 14 февраля 2020 г. Промо

Краснодар станет первым в 2020 году местом, где пройдет региональная встреча IT-специалистов сообщества Инфостарт. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Стоимость участия - 5000 рублей. Цена действительна до 26.12.2019.

Полезные процедуры и функции для программиста

Статья Программист Нет файла v8 1cv8.cf Россия Абонемент ($m) Практика программирования Универсальные функции

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

1 стартмани

07.10.2019    15185    4    HostHost    24       

Описание формата внутреннего представления данных 1С в контексте обмена данными

Статья Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных Разработка

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    8296    7    Dementor    27       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Конвейер проверки качества кода

Инструменты и обработки Программист Архив с данными v8 1cv8.cf Windows Абонемент ($m) Инструментарий разработчика Практика программирования Математика и алгоритмы Разработка

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    9638    16    Stepa86    37       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Вам нравятся запросы в 1С?

Инструменты и обработки Программист Конфигурация (md, cf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования Разработка

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    12685    1    m-rv    79       

1С:Ассемблер. Немного летнего веселья!

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Разработка

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    17923    55    Evil Beaver    116       

Базовый курс по управлению ИТ-проектами. Курс проходит с 26 февраля по 22 апреля 2020 года. Промо

Отличительная черта курса - органичное сочетание трех вещей: 1.Теория проектного управления (PMI®+Agile Alliance+Российские ГОСТ+Методологии от 1С); 2. Опыт внедрения продуктов 1С (опыт франчайзи и успешных компаний + тренды Infostart Event и Agile Days); 3. Разбор реальных проблем и рекомендации экспертов по проектам слушателей. Мы будем фиксироваться на тех инструментах, которые реально оказываются полезными в практике руководителей проектов внедрения. Ведущая курса - Мария Темчина.

от 11000 рублей

Простые примеры сложных отчетов на СКД

Статья Программист Архив с данными v8 v8::СКД 1cv8.cf Абонемент ($m) Практика программирования

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    17912    16    Hatson    22       

Безопасная работа с транзакциями во встроенном языке

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    19738    8    tormozit    44       

PgConf.Russia 2020. 3-5 февраля 2020 г. Москва. Промо

PGConf.Russia – международная техническая конференция по открытой СУБД PostgreSQL, ежегодно собирающая более 700 разработчиков, администраторов баз данных и IT-менеджеров для обмена опытом и профессионального общения. Для участников сообщества infostart.ru скидка 5% на участие в конференции.

от 12350 рублей

HTML в новой версии 8.3.14 на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки Практика программирования Разработка

Тестируем возможности HTML в новой версии 8.3.14 платформы на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX.

1 стартмани

29.01.2019    17805    70    Synoecium    40       

Базовый курс по разработке мобильных 1C-приложений для Android-устройств. Третий поток. Онлайн-интенсив с 11 февраля по 05 марта 2020 г. Промо

Данный онлайн-курс предусматривает изучение базовых принципов создания приложений для операционной системы Android, работающих на мобильной платформе “1С:Предприятие”. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие” при разработке прикладных решений для “обычных” компьютеров, но пока ещё не занимался разработкой 1С-приложений, предназначенных для работы на мобильных устройствах.

7500 рублей

Отладка сложных отчетов на СКД

Отчеты и формы Программист Расширение (cfe) v8 v8::СКД 1cv8.cf Россия Абонемент ($m) Практика программирования

Расширение для отладки сложных отчетов на СКД (в т.ч. для собираемых программно "на лету") и быстрого перехода к отладке таких отчетов в консоли запросов и отчетов на СКД.

1 стартмани

28.12.2018    17302    63    maxx    58       

Реализация простого http-сервиса "Просмотр карточки номенклатуры(товара) в браузере"

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Практический пример реализации простого http-сервиса средствами 1С Предприятие 8.3. Обеспечивает просмотр списка товаров и просмотр данных товара в браузере.

1 стартмани

07.12.2018    15899    12    dmitry1975    31       

Базовый курс для начинающих 1С-программистов. Пятый поток. Онлайн-курс с 12 февраля по 15 апреля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500/9500 рублей

Использование подсистемы БСП "Заполнение объектов"

Статья Программист Расширение (cfe) v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Практика программирования Универсальные функции БСП (Библиотека стандартных подсистем)

Применение механизмов БСП для добавления новых команд заполнения к формам различных объектов. Использование расширений конфигурации для доработки. Шаблоны для реализации собственных команд заполнения.

1 стартмани

23.11.2018    16727    10    ids79    23       

Работа с публикациями "Инфостарт"

Инструменты и обработки Программист Архив с данными v8 УУ Абонемент ($m) Практика программирования О сообществе WEB

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    11792    12    RocKeR_13    16       

Открыто голосование за доклады на INFOSTART MEETUP Krasnodar Промо

Выбирайте и голосуйте за самые интересные доклады, лучшие из них попадут в окончательную программу митапа. Голосование продлится до 30 января 2020 года.

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Инструментарий разработчика Практика программирования

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    20470    32    dsdred    13       

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструменты и обработки Программист Бизнес-аналитик Приложение (apk) v8 Windows Абонемент ($m) Инструментарий разработчика Практика программирования

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    18546    23    informa1555    26       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

Работа с данными выбора

Инструменты и обработки Программист Архив с данными v8 Россия Абонемент ($m) Практика программирования Работа с интерфейсом

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    27050    16    kalyaka    16       

HTTP Сервисы: Путь к своему сервису. Часть 1

Статья Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Практика программирования WEB

Уже много было написано про http-сервисы, но то и дело всплывают «Новые» статьи по обмену между базами V8 по COM, что «Немножко» удивляет. Решил внести свои 5 копеек, поработаем с http-сервисом.

1 стартмани

15.07.2018    48191    19    dsdred    24       

Онлайн-курс «Практические аспекты внедрения регламентированного учета и расчета себестоимости в 1С:ERP на крупных промышленных предприятиях» с 17 февраля по 13 марта 2020 года. Промо

Курс рассчитан для подготовки экспертов по регламентированному учету и учету затрат для внедрения на крупных промышленных предприятиях с «исторически сложившимся» учетом

9000 рублей

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар")

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    21903    86    m-rv    57       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования БСП (Библиотека стандартных подсистем)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    31870    30    dsdred    36       

Как выполнить отчет на СКД через COM и получить данные отчета?

Статья Программист Архив с данными v8 УПП1 Россия Windows Абонемент ($m) Практика программирования

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    20026    10    wowik    3       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Работа со схемой запроса

Статья Программист Конфигурация (md, cf) v8 v8::Запросы Абонемент ($m) Инструментарий разработчика Практика программирования

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    32054    77    kalyaka    34       

Заполняем по шаблону (по умолчанию)

Инструменты и обработки Программист Архив с данными v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    19713    20    mvxyz    17